Can't Add FX on Master or Sends, anyone else experiencing this?

First of all, well done Sunhouse - sensory percussion is incredible! I’ve always found programming drums to be such a painstaking and disappointing task - I could never get the ideas in my head out fast enough with a keyboard and mouse, and even when I did it sounded flat - using the kit in such a natural way has totally changed the way I produce music. Thank you!

I’ve been using the pad FX on each drum rather than using the sends but I’ve started to record into my DAW and I was trying to seperate the audio from the FX but when I tried creating a reverb or delay on either Send 1, Send 2 or the Master bus nothing happens…

I’m using Sensory Percussion version 1.3.2 on a Macbook Pro running El Capitan 10.11.6. I’ve tried reinstalling the software and rebooting my laptop - problem still occurs. I don’t think it would have anything to do with my audio interface but I’m using Focusrite Clarett 4Pre.

Just to clarify all the FX work fine on Drums 1-4.

Anyone else experiencing this issue?


Can you send an email to That way our whole team can correspond with you a little better and figure out what the issue could be.

The only thing I can think that it could be (without seeing a short video of your problem) is that perhaps you got used to using pad FX and are trying to use those on the send and master channels (which have no pads) instead of dragging or adding effects to the channel slot.

If this is not the case, please send a short video of what it is happening to our support email and we will figure out what is going on.

Mate, you’re a genius!..wish I could say the same for myself haha.

Thanks for your prompt reply.