Midimapping the "next" button

Hey There, I would like to map the “next” button in the top left corner with my midi fighter twister, to skip the song list. I created a midi input, The midi fighter shows cc signal. I chose the right number for the button. But I can’t assign the button from the midifighter to the “next” button in the top left corner.

Thanks for your support
Kind regards
Till

Hi @Till you can make assignments to buttons with CC knobs, but it would be really hard to control. Each time you turn the knob the next button would trigger for each CC message it receives. And you would need two knobs, one for next and one for previous.

I think what would work better is to use Program Change messages if MIDI Fighter Twister supports that.

With 2.1.8 we added Program Change input to control the active Set. You just need to enable it in the settings and it should work automatically. No need to even create a MIDI Hardware input or any assignments.

If you can set one of your knobs to use Program Change, I think that would be the way to go.

1 Like

Hey There Tenoch,

there is still the problem of midi mapping the “next” button in the top left corner. It seems that the assignment menu isn’t working. I can easily assign the volume of a snare with the midi fighter, but the “next” button isn´t working. I send you a video via email . Thanks for your support.
Kind regards till

Hi @Till - looks like there’s a bug here (thanks for your video). Our team is looking into this and we’ll try to get a patch release out soon to fix this. Thanks!!

I’ve also had this same issue but haven’t had time to contact tech support. I’ve also had issues with ‘saving’ the midi mapped next button. In previous versions I could make the mapping but it would be lost when the session was closed despite saving my session. Other midi mappings seemed to save fine.

Hi @Bongo_Bill

Thanks for your report. We’re fixing all these issues with session-level assignments on the next/previous button and they’ll be out in the next release.

In the meantime, I’d recommend you try using Program Change to control the selected set. You just need to enable it in the MIDI settings tab in the Preferences window.

Let me know if you have any questions.

Sounds great! Thank you!

I must be misunderstanding the nature of this, I guess. I am hoping I can use a set of BT-1’s through a module to toggle through sets - is that possible? I can’t seem to get any midi input to work from td-50x or spd-sx pro.