Pickup elements or sensors impossible to place correctly with vintage Gretsch drum hoops?

Got a new V2 kit for xmas :slight_smile: But unfortunately, nothing is working. It all hooks up ok, powers on, triggers light up on the portal as connected, and the portal connects to the software and is recognized as an audio interface. But that’s as far as I can get - the software will not let me train because nothing appears to be triggering no matter what I try.

(Also it’s not clear to me after going through documentation if there is supposed to be additional light activity on the actual portal when playing? The inputs are lit up, but are they supposed to flash a different color showing trigger activity? Secondly, I noticed after powering on the Sunhouse logo in the top left corner of portal lights up, and then goes away. Is that normal, or is it supposed to stay lit or flash with triggering? In any case it stays unlit after that brief second).

Anyway, after doing some further investigation at my setup, I realized that all of the pickup elements are off from the sensor light by what I’d estimate is a half-inch, so it’s not negligible! See these pictures – it’s really hard to show accurately with my phone camera but I added some circles and arrows to point out what I mean.

Sorry the forum also won’t allow me to embed more than one image so I had to upload everything to a drive link - Sensory Percussion V2 issue - Google Drive

As you can see, the pickup elements are quite a bit off, and in the third image the initial pickup guide is placed correctly in case you’re thinking that part was screwed up.

So then I investigated the trigger mount on the rear side where it attaches to the hoop and shell, and noticed that my hoop doesn’t have quite the available depth as illustrated in the manual pictures and many online videos for Sensory Percussion. Basically it’s impossible for the trigger to mount any closer in, because the way the hoop and the shell meet with no groove in between (as illustrated by the last 3 images in the sensor rear view).

I’m assuming this has to do with simply how the drum was designed – note that it’s a Vintage early 1960’s Gretsch Round Badge (pre-serial #), so with vintage gear there’s always some kind of quirks…

I did assume that I could simply “cheat” the pickup elements forward to compensate for this issue, by snipping off an approximate 1/2" or so from the metal guides using shears, and then that updated guide would get the elements under the sensor. I tested this just on one drum and visually from my vantage point the pickup element does seem to be right under the light, so I thought maybe I solved this… but still nothing! No activity on the portal or in the software. Not sure why that fix wouldn’t work unless even the slightest fraction of a millimeter off entirely makes or breaks it (which would seem rather unforgiving and unrealistic)?

Has anyone else encountered this type of issue, and if so what is your solution? Should I replace the hoops themselves? (of course I’d save the originals too)

Thanks for reading!

Hi @wing,

The first issue could be that you haven’t given Sensory Percussion 2 Microphone permissions (if you are on a Mac OS): System Preferences>Privacy & Security>Microphone

If this is not the issue, please write an email to support@sunhou.se and include a video of the issue (you hitting the drum, and signal not showing up in Sensory Percussion 2).

For your other issue: your sensor attachment actually looks pretty good to me. The light should shine behind the pickup element.

Let us know of your progress.


Hi, thanks for responding! Unfortunately that was already given permission… but I actually got it to work after all – turns out it was the USB-C hub I was plugged into. Limited ports on these newer Mac Studios… but I tried another USB hub and strangely that fixed everything. The Sunhouse logo stays lit now when connected to the software, and training works!

The reason I was confused about the trigger placement is the official setup video (around ~5:00) says “when powered, the LEDs on the sensor should light up directly above the pickup elements.” And it has this from the 3D rendering which isn’t clear but kinda suggests the LED is above the pickup -

The way that attaches to the hoop looks different than my setup which is why I thought maybe it was an issue with the design of my vintage drum hoops or something. So to be clear you’re saying it’s fine either way?

Are you using USB-C to USB-C, or an adaptor cable? When I’ve done USB-C to USB 2.0, or USB-A adaptors….sometimes flipping the USB side 180° has fixed the issue for me.

1 Like

With Mac USB ports….sometimes one of their ports is low data/low or zero power transfer and you want to make sure you are plugged into a port that can provide power AND data both directions. I don’t use a Mac Studio but I have an M1 Macbook Pro and have experienced these bizarre Apple issues lol

1 Like

I was using a USB-C hub… no idea but it didn’t seem to like it. Ironically I’m now using another hub I had which was for USB3.0, and used the included USB-C to USB-A adapter, and that fixed it. Go figure!