Problems with V2 software training drums


I’m in the process of trying to train my drums in the guided setup and I keep having issues with the software not registering zones to move on to the next section or level. For example, I’ve tried multiple times to set level 3 snare training and I’ve gone through all the steps (damped,stickshot and shell). However, when I click on finish level at the end only the damped shows as registering any hits. I get similar results trying to register level 2 and level 3 for the Tom input. The bass drum has been fully trained.This is really quite frustrating and should NOT be an issue for a gear setup that costs as much as this does.

Running Windows 11 on an Intel NUC with I7 processor, a 1TB M.2 hard drive and 32GB RAM. I have plenty of processing power to handle the Sensory software.

Please advise.



Hi Kevin,

Can you send a short video of the issue to This is the first time an issue like this has been reported, so it would be helpful to see exactly what is happening?

We can help troubleshoot this more via the support email, but one thing to check would be if those zones can be trained in manual mode:


Hello again,

I decided to uninstall/resintall the Sensory 2.0.3 software and that almost worked 100%. The level/zone that doesn’t retain any hit counts when training the drums is my Tom sensor, Level 3 advanced in the shell zone. Even if I attempt to train it in manual mode it will not retain the hit counts.

However, I did install the Beta 2.0.4 software and the drum training completed without issue for all sensors. I will continue to use the Beta software until a new release version is available.