Use MIDI cc with SP ableton plugin

hi guys,
i’m using the SP plugin into ableton having a lot of fun, but i really can’t understand how to map SP midi cc’s into ableton parameters: anyone can help?
this are my steps:

  • create a midi cc knob into SP Plugin, as always;
  • press command-m to open the midi mapping function into ableton
  • select the parameter i want to assign clicking on it (and when i do this the selected track automatically change, so the next click i have to do is to select the SP plugin track and when i move the virtual cc it assigns to his own track control…

what i’m doing wrong?
thnx

Hi there Max,

Yes, controlling knobs and faders in Ableton with the plugin is actually a bit more complicated than doing it over an IAC bus from the standalone app.

Using the plugin, you either have to route the MIDI out and back in via a virtual bus, or use a Max for Live device from the building tools pack . The virtual bus method is complicated by the fact that Ableton strips MIDI channel information coming out of plugins: so all of the MIDI information coming from the Sensory Percussion will be condensed to one channel.

The Max Api CtrlMIDIcc.amxd is the device from the building tools Max for Live pack makes it possible to send CCs from the Sensory Percussion plugin to Ableton’s UI.

@Mason has made awesome tutorials for both of those techniques:

1 Like

i’ve tried but still can’t go through…

Thanks for the video!

That was helpful. I think you just need to select SP plugin as the device’s input:

Screen Shot 2020-04-20 at 4.05.30 PM

Let me know of your progress.
Best,

mmno…
it does not work.

Thanks for the additional information.

Now I think you just need to send CC1 from Sensory Percussion to see the input.

In the screenshot below I have that device listening for CC2:

Screen Shot 2020-04-20 at 4.32.09 PM

And here is the CC in the SP plugin that it is listening for:

Screen Shot 2020-04-20 at 4.32.36 PM

There’s no need to send MIDI out of the Ctrl MIDIcc channel. You can press the “map” button in the bottom right corner to map it to a parameter inside Live

Yes, now it works. The problem was that innthe sp plug-in the cc was (in default setting) set to “0” so I wasn’t able to see it in the max device.
Thank you!

1 Like