VST Plugin in Ver 2.2 and how to install it

The VST.3 Plugin that goes with Ver. 2.2. is not loading in Live, nor showing up after rescanning the plugin folders and restarting my Mac.
In the Sensory Percussion Settings, it shows up as installed and is located in the correct location path, but it will not load in Live 11.

Can anyone verify that it works and explain how to install and activate it?

I’ve also been having issue with the VST since the version that runs on 10. Both this ver 2.2 and the old one fail to load “because they can’t be found”

I checked a million times the folder settings are correct, and tried custom folders to read plugin on ableton and non custom.

This is super frustrating and my SP has been collecting dust because I can not record from not only ableton, but Ive tried with other DAW’s and the audio streamer with no luck.

Same issue for me. When I look in the directory, I see the plug-in, but instead of my Mac registering it as a plug-in, it’s coming up as an alias. Any help from Sunhouse would be appreciated here.

Hi all,

Sorry that you’ve been having trouble getting Ableton to recognize the plugin. I’ve been there before with various newly installed plugins and I know it can be frustrating seeing the file in the correct place, but not having Ableton recognize it. Ableton’s plugin scanning is notoriously finicky and can require some brute force troubleshooting. Here is the official Ableton guide:

The file installed in your VST3 folder should be an alias; that’s not an error. It directs to the .vst3 file inside of the app (/Applications/Sensory Percussion 2.app/Contents/MacOS/Sensory Percussion 2.vst3).

We can assure you that the Sensory Percussion 2 plugin is working and many users have installed it and are currently using it in their DAW. I wish we had a better one-size-fits-all fix for this issue, but the reasons that a plugin isn’t being recognized can vary based on a lot of factors outside of our control, given that it’s more of an Ableton issue than a Sensory Percussion issue. If you try all the steps in the Ableton guide and it’s still not being recognized, shoot us a message at support@sunhou.se with the following info:

  • the version of Ableton you’re using
  • the OS you’re using
  • screenshots/screen recordings of what you’re seeing in Ableton when you open the plugin template and navigate to the track that holds the plugin, as well your plugin folder settings

Thanks for your patience. We’ll do our best to get you up and running and recording SP!